Z/IP DHCP and Reachability


#1

First question.
I have my Z/IP inserted in my department lab. No sensors attached or included.When I start the Z/IP with this command:
/usr/local/sbin/zipgateway -e /tmp/eeprom.dat -t /usr/local/etc//zipgateway.tun -c /usr/local/etc/zipgateway.cfg -s /dev/ttySC1
I get this log

594067671 ZIP_Router_Reset: pan_lladdr: f6:d6:0f:ce:00:01 Home ID = 0xce0fd6f6 
594067671 Tunnel prefix :: 
594067671 
594067671 Lan address fd00:aaaa::03 
594067671 
594067671 Han address fd00:bbbb::01 
594067671 
594067671 Gateway address fd00:aaaa::1234 
594067671 
594067671 Unsolicited address fd00:aaaa::1234 
594067671 
ECDH Public key is 
33996-60314-23566-07427- 
29786-40546-14795-55436- 
29210-41963-07456-09582- 
08807-02285-18718-50482- 
594067982 DTLS server started 
594067982 mDNS server started 
594067982 DHCP client started 
594067982 Starting zip tcp client 
594067982 ZIP TCP Client Started. 
594067982 No portal host defined. Running without portal. 
594067984 DHCP client started 
fd00:bbbb::01

fd00:aaaa::03

fe80::21e:32ff:fe1c:e50e

594069772 Comming up 
sh: 0: getcwd() failed: No such file or directory 
sh: 0: getcwd() failed: No such file or directory 
sh: 0: getcwd() failed: No such file or directory 
temp_assoc_virtual_nodeids (4): 28 29 30 ... 31 
594069865 virtual_nodeid_init_count: 4 
594069881 Bridge init done

594075034 DHCP pass completed 
594075034 update flag 1 129 
594075038 got OFFER 
594075038 send REQUEST 
594075043 got ACK 
594075043 Node 1 has ipv4 address 192.168.1.131 
594075043 Checking for new sessions 
594075043 We should send a discover 
594075043 New IPv4 assigned for node 1 
594075043 Sending DISCOVER 
594075047 got OFFER 
594075047 send REQUEST 
594075051 got ACK 
**594075051 Node 8 has ipv4 address 192.168.1.132** 
594075051 Checking for new sessions 
594075051 New IPv4 assigned for node 8 
594075051 nm_fsm_post_event event: NM_EV_DHCP_DONE state: NM_IDLE 
sh: 0: getcwd() failed: No such file or directory 
594075056 DHCP pass completed 
594075056 update flag 1 129

The Z/IP assigned an IP to Node 8??? I checked and that is a machine on my Department Network!
How can I prevent the Z/IP DHCP assigning IP to machines which are not zwave devices?

Secon question
I can’t reach the Z/IP:

root@raspberrypi:/opt/zwportal/src/zwave/hcapi/demos# ip -6 route add fd00:bbbb::/64 via fd00:aaaa::3
RTNETLINK answers: No route to host
root@raspberrypi:/opt/zwportal/src/zwave/hcapi/demos# cd gw_discovery
root@raspberrypi:/opt/zwportal/src/zwave/hcapi/demos/gw_discovery# ./gw_discovery
Scanning for Z/IP gateway ...
Press 'x' to exit ...
Found 0 network interfaces

Received report:0/0 with gw count:0
The system has no valid IP, please configure it.

The ifaces are as follow:
br-lan: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.137 netmask 255.255.255.0 broadcast 192.168.1.255
ether b8:27:eb:f0:43:81 txqueuelen 1000 (Ethernet)
RX packets 14333817 bytes 3698840622 (3.4 GiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 75867 bytes 13629331 (12.9 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500               
        ether b8:27:eb:f0:43:81  txqueuelen 1000  (Ethernet)             
        RX packets 14904281  bytes 3946079054 (3.6 GiB)                  
        RX errors 0  dropped 2958  overruns 0  frame 0                   
        TX packets 402775  bytes 38167671 (36.3 MiB)                     
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0       
                                                                         
eth0.1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500             
        inet6 fe80::ba27:ebff:fef0:4381  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:f0:43:81  txqueuelen 1000  (Ethernet)      
        RX packets 0  bytes 0 (0.0 B)                             
        RX errors 0  dropped 0  overruns 0  frame 0               
        TX packets 9871  bytes 3372524 (3.2 MiB)                  
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
                                                                  
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536                      
        inet 127.0.0.1  netmask 255.0.0.0                         
        inet6 ::1  prefixlen 128  scopeid 0x10<host>              
        loop  txqueuelen 1  (Local Loopback)                      
        RX packets 11  bytes 539 (539.0 B)                        
        RX errors 0  dropped 0  overruns 0  frame 0               
        TX packets 11  bytes 539 (539.0 B)                        
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tap0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::f890:4cff:fe9f:5a48  prefixlen 64  scopeid 0x20<link>
        ether fa:90:4c:9f:5a:48  txqueuelen 1000  (Ethernet)
        RX packets 20  bytes 5800 (5.6 KiB)
        RX errors 0  dropped 4  overruns 0  frame 0
        TX packets 15  bytes 1873 (1.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

#2

Hi,

It is not clear from the first log, where the Z/IP gateway assigns an IP for Node 8. Can you help to make this more clear?

For the second questions. Are you using the pre-build RaspberryPi image from Z-Wave Public, or are you running the Z/IP gateway on your own hardware? Can you Ping the Z/IP gateway?

BR
Carsten


#3

Hi,

For second question.
Are you using bridged (br-lan) setup?
If yes, Then I dont see the bridge up. May be you should bring the bridge br-lan up and add tap0 and the appropriate network interface to it.
If no (not using bridge) then tap0 should have an IP6 in the same prefix as gateway(fd00:aaaa::).
Do you have ipv6 forwarding enabled? That prevents the interfaces to acquired auto IPV6 configuration sent by gateway.

For first question. Try default setting gateway and see if the node 8 still shows up?