Setting a PSK in Z-Ware CE rendered UZB Bridge useless


Hi. I have just bought a Sigma UZB Bridge stick, and it was working fine with the ZWare portal /ZIP.

I was adding a door lock to test, and figured out a PSK was not set, as it was included as S0 / Unauthenticated.

I went into the GUI to try to assign a PSK (it was valid, 16 bytes). The key went through GUI validation (if any?) but the process failed.

After that point the UZB is useless, and after rebooting the Pi3, the UZB-stick is found as usual (lsusb) but not initialized. What to do next? Or more specifically; how can I reset the stick to its original state? @z-wavesupport?


I should add that I have already tried re-installing the ISO on the SD, and the situation is unchanged…


@TheOne? Is there anyone here?



I am not sure which GUI you are referring to? Please let me know so that I can guide you.

Generally there are no available S2 devices, so all devices will be included as S0/unauthenticated.

Best regards,


I’m referring to the GUI on the Raspberry Pi image -> ZWare web application. I log in with “sigma” and “sigmadesigns”. In there you are able to manage the Z-wave network among other things.

There is a field for entering a key that is to be used as a cryptographic key used for securing S0 communications if I understand the GUI right. I used the field to set the key. And after a short while of waiting the whole application went “blank”; imao. no devices were shown, and even the UZB hardware disappeared.

I am aware that there are no S2 devices currently. The case is that I am not happy with including a lock device without any form of security. Does the status “S0/Unauthenticated” actually mean that the communication is encrypted with the legacy security mode? It is a bit ambiguous…

I tried restarting, with no luck. I also tried reinstalling the image on the Raspberry with no luck. The hardware is no longer usable / detectable.

So the situation is like this:

I bought a UZB Bridge device that suddenly is not usable with the Raspberry Pi image. The key I entered is also lost. So the only outcome as I see it would be to reset the hardware. But how do I do it? I guess there is a key set somewhere in a config file that does not correspond to the actual key in the hardware.



Is this what you are referring to:

If so, this is not the S0 key, but a DTLS PSK used for the encryption between Z/IP Gateway and it’s clients. The key must be identical on Z/IP Gateway and the Z-ware portal. On Z/IP Gateway it can be configured in the file /usr/local/etc/zipgateway.cfg:

The default key is:

If your log file looks like this after starting Z/IP Gateway:

Your UZB is registering correctly.

Best regards,


Ok, thanks - I will have a closer look at this tonight. I suspect that a key discrepancy between the software components on the raspberry pi is not the problem, as the hardware does not even work on a fresh install with default keys.

There must be some invalid data in the hardware itself as a consequence of setting the mentioned PSK. Is that a correct assumption? (a copy of the key exists in zipgateway, zware AND the ZIP dongle itself?)


Finally, I nailed it.
I had to reinitialize from the same /ui/eng/settings.shtml page using the default PSK key, and the hardware reappeared in the GUI.


Happy you solved it! :slight_smile: