Node wake up causes unnecessarily communication


#1

Hi there,

I have a Danfoss eTRV which after waking up will send all it’s relevant information such as temperature, setpoint, battery and wake up info through multi command encapsulation to the controller node (node 1)

My network consist of two nodes, the controller node(node 1) and eTRV (node 6)

I want to know what is node 3 and why does it makes all the redundant calls. I believe this has caused the TRV to stay up way more than needed which drains the battery quite fast (TRV stays awake for 15 sec draining 30mA per second, reduced battery life to 60 days)

here is the sniff file of the communication:

time source destination data application
12:35:40.178 006 001 Singlecast Multi Cmd Encap
12:35:40.185 001 006 Ack
12:35:41.675 003 006 Singlecast Multilevel Sensor Get
12:35:41.681 006 003 Ack
12:35:41.687 006 003 Singlecast Multilevel Sensor Report
12:35:41.701 003 006 Ack
12:35:41.952 003 006 Singlecast Thermostat Setpoint Get
12:35:41.959 006 003 Ack
12:35:41.966 006 003 Singlecast Thermostat Setpoint Report
12:35:41.974 003 006 Ack
12:35:42.247 003 006 Singlecast Battery Get
12:35:42.254 006 003 Ack
12:35:42.259 006 003 Singlecast
12:35:42.269 003 006 Ack
12:35:44.543 003 006 Singlecast Wake Up No More Information
12:35:44.549 006 003 Ack
12:36:00.075 003 006 Singlecast NOP
12:36:00.114 003 006 Singlecast NOP
12:36:00.153 003 006 Singlecast NOP
12:36:00.181 003 006 Singlecast NOP
12:36:00.204 003 006 Singlecast NOP
12:36:00.228 003 006 Singlecast NOP
12:36:00.334 003 006 Singlecast NOP
12:36:00.403 003 006 Singlecast NOP
12:36:00.471 003 006 Singlecast NOP
12:36:00.499 003 006 Singlecast NOP
12:36:00.552 003 006 Singlecast NOP
12:36:00.605 003 006 Singlecast NOP
12:36:00.632 003 006 Explorer Normal NOP

please let me know if any other information is needed


#2

Thank you for your valuable feedback, Ali. This behaviour is actually specified in the User Guide as ‘background polling’ to ensure a valid cache. However as you have indicated, it does have a detrimental impact on device battery life. We shall certainly be looking into improving our polling strategy. Stay tuned :slight_smile:


#3

Hey Miskit, thanks for your reply, At this point I am wondering if there is a way to disable background polling. Currently we are running on version 7.38 and I’ve noticed in version 8.12 using cmd_cls_cfg_file it is possible to disable polling. Is there a way to keep it disable in 7.38 version? Also do you think background polling can actually cut the battery life to one fifth?

Unfortunately updating to version 8.12 wont be that painless for us so we are trying to be sure of the result before starting the migration.


#4

hey Ali. we haven’t gotten round to fully measuring this yet especially since it would be device-specific but we do believe it will help. regardless, it would be good to move to v8.12, so that you can avail of the Z-Wave SmartStart feature as well. do also let us know of your migration pains, so we can better structure our docs to help with migration.