Z/IP / Z-Ware : List Nodes


#1

zwnet_get_node_list returns:

<?xml version="1.0"?>
<zwave>
    <node desc="1" id="1" vid="0" pid="1" type="1" category="0" alive="1" sec="1" sec_incl_failed="0" lib_type="7" proto_ver="4.34" app_ver="4" app_sub_ver="37" sensor="0" sleep_cap="0" wkup_intv="0" s2_keys_valid="0" s2_grant_key="0" s2_dsk="">
        <zwnode_ext_ver hw_ver="1">
            <zwnode_fw target="1" ver="2" sub_ver="60"/>
            <zwnode_fw target="2" ver="1" sub_ver="0"/>
            <zwnode_fw target="3" ver="1" sub_ver="0"/>
        </zwnode_ext_ver>
    </node>
    <node desc="17" id="17" vid="271" pid="4097" type="1538" category="0" alive="1" sec="1" sec_incl_failed="0" lib_type="0" proto_ver="0.00" app_ver="0" app_sub_ver="0" sensor="0" sleep_cap="0" wkup_intv="0" s2_keys_valid="1" s2_grant_key="128" s2_dsk=""/>
    <node desc="21" id="21" vid="0" pid="0" type="0" category="0" alive="0" sec="1" sec_incl_failed="0" lib_type="0" proto_ver="0.00" app_ver="0" app_sub_ver="0" sensor="0" sleep_cap="1" wkup_intv="0" s2_keys_valid="1" s2_grant_key="0" s2_dsk=""/>
    <node desc="22" id="22" vid="0" pid="0" type="0" category="0" alive="0" sec="1" sec_incl_failed="0" lib_type="0" proto_ver="0.00" app_ver="0" app_sub_ver="0" sensor="0" sleep_cap="1" wkup_intv="0" s2_keys_valid="1" s2_grant_key="0" s2_dsk=""/>
    <node desc="23" id="23" vid="0" pid="0" type="0" category="0" alive="0" sec="1" sec_incl_failed="0" lib_type="0" proto_ver="0.00" app_ver="0" app_sub_ver="0" sensor="0" sleep_cap="1" wkup_intv="0" s2_keys_valid="1" s2_grant_key="128" s2_dsk=""/>
    <node desc="26" id="26" vid="271" pid="4097" type="1793" category="0" alive="1" sec="1" sec_incl_failed="0" lib_type="3" proto_ver="4.05" app_ver="3" app_sub_ver="2" sensor="0" sleep_cap="1" wkup_intv="4200" s2_keys_valid="1" s2_grant_key="128" s2_dsk="">
        <zwnode_ext_ver hw_ver="1"/>
    </node>
    <zwnet utime="1496050933" id="01-02-03-04-05-06-07-08">
        <zwnode desc="1" id="1" vid="0" pid="1" type="1" category="0" alive="1" sec="1" sec_incl_failed="0" lib_type="7" proto_ver="4.34" app_ver="4" app_sub_ver="37" sensor="0" sleep_cap="0" wkup_intv="0" s2_keys_valid="0" s2_grant_key="0" s2_dsk="">
            <zwnode_ext_ver hw_ver="1">
                <zwnode_fw target="1" ver="2" sub_ver="60"/>
                <zwnode_fw target="2" ver="1" sub_ver="0"/>
                <zwnode_fw target="3" ver="1" sub_ver="0"/>
            </zwnode_ext_ver>
        </zwnode>
        <zwnode desc="17" id="17" vid="271" pid="4097" type="1538" category="0" alive="1" sec="1" sec_incl_failed="0" lib_type="0" proto_ver="0.00" app_ver="0" app_sub_ver="0" sensor="0" sleep_cap="0" wkup_intv="0" s2_keys_valid="1" s2_grant_key="128" s2_dsk=""/>
        <zwnode desc="21" id="21" vid="0" pid="0" type="0" category="0" alive="0" sec="1" sec_incl_failed="0" lib_type="0" proto_ver="0.00" app_ver="0" app_sub_ver="0" sensor="0" sleep_cap="1" wkup_intv="0" s2_keys_valid="1" s2_grant_key="0" s2_dsk=""/>
        <zwnode desc="22" id="22" vid="0" pid="0" type="0" category="0" alive="0" sec="1" sec_incl_failed="0" lib_type="0" proto_ver="0.00" app_ver="0" app_sub_ver="0" sensor="0" sleep_cap="1" wkup_intv="0" s2_keys_valid="1" s2_grant_key="0" s2_dsk=""/>
        <zwnode desc="23" id="23" vid="0" pid="0" type="0" category="0" alive="0" sec="1" sec_incl_failed="0" lib_type="0" proto_ver="0.00" app_ver="0" app_sub_ver="0" sensor="0" sleep_cap="1" wkup_intv="0" s2_keys_valid="1" s2_grant_key="128" s2_dsk=""/>
        <zwnode desc="26" id="26" vid="271" pid="4097" type="1793" category="0" alive="1" sec="1" sec_incl_failed="0" lib_type="3" proto_ver="4.05" app_ver="3" app_sub_ver="2" sensor="0" sleep_cap="1" wkup_intv="4200" s2_keys_valid="1" s2_grant_key="128" s2_dsk="">
            <zwnode_ext_ver hw_ver="1"/>
        </zwnode>
    </zwnet>
</zwave>

As you can see, there is no category given with Node 1, 17 and 26, the others are sleeping, thats okay. But why I do net get a category?

Regards,
Daniel